GeoPlace Services website and LA Dashboard login issues

Incident Report for GeoPlace LLP

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 09:59 BST

Investigating

We are aware there are problems logging into services.geoplace.co.uk and the LA Dashboard. We are working to resolve these as soon as possible. We will update this incident when the problem has been fixed or when we have an expected time that the sites will be available again.
Posted Jul 16, 2026 - 09:28 BST
This incident affected: GeoPlace services website (Coordinates review tool, GeoGateway Address, GeoGateway Street, Register for street services, Search, Street data download, Street data upload, Technical guidance documents for local authorities, Website login, Where's my COU?) and LA Dashboard.