Findmystreet, DataVia and HAUC App unavailable

Incident Report for GeoPlace LLP

Resolved

Findmystreet, DataVia and the HAUC App are now available. Thank you for your patience.
Posted Aug 18, 2026 - 09:35 BST

Investigating

There have been reports that Findmystreet, DataVia and the HAUC App are unavailable this morning. The issue is being investigated and we will provide an update when we have more information.

Findmyaddress remains offline due to ongoing maintenance.
Posted Aug 18, 2026 - 09:23 BST
This incident affected: DataVia API, FindMyAddress website, FindMyStreet website, and HAUC(UK) app.