FindMyStreet not returning results
Incident Report for GeoPlace LLP
Resolved
This incident has been resolved.
Posted Jan 21, 2025 - 13:56 GMT
Investigating
14:30 20th January 2025. We have identified the issue and have implemented a fix. You should see an improvement in the performance, though we will continue to monitor this for the next 24 hours just to be safe. Next update, 14:30 21st January
Posted Jan 20, 2025 - 11:37 GMT
This incident affected: FindMyStreet website.