Findmyaddress service available during business hours (8.30-17.30 Mon-Fri)

Incident Report for GeoPlace LLP

Update

FindMyAddress is currently only be available during business hours (08:30 to 17:30) Monday to Friday (excl bank holidays) while we do some testing on site stability. This can only be done during business hours. We are hoping to resume normal service as soon as possible.
Posted Aug 24, 2026 - 16:08 BST

Monitoring

For the foreseeable future, FindMyAddress will only be available during business hours (08:30 to 17:30) Monday to Friday. The site will remain closed over weekends and bank holidays.
Posted Aug 24, 2026 - 08:49 BST

Update

FindMyAddress is now closed for essential maintenance over the weekend and will be available from 9:00 on Monday 24th August.
Posted Aug 21, 2026 - 17:34 BST

Update

FindMyAddress is now available, essential maintenance is required from 17:30 21st August, the site will be offline over the weekend and restored on Monday 24th August. we are sorry for any inconvenience this may be causing.
Posted Aug 21, 2026 - 13:14 BST

Update

We are continuing to work on a fix for this issue.
Posted Aug 21, 2026 - 13:11 BST

Update

FindMyAddress is now available, essential maintenance may still be required and we will keep you updated. Sorry for any inconvenience this may be causing.
Posted Aug 21, 2026 - 13:06 BST

Update

We are sorry that findmyaddress is still offline. We are waiting for confirmation on when this will be available and will provide another update this afternoon.
Posted Aug 21, 2026 - 12:53 BST

Update

Findmyaddress.co.uk is still offline. We are waiting on confirmation of availability for tomorrow (Friday) and will provide an update tomorrow morning. Sorry for any problems or delays this is causing you.
Posted Aug 20, 2026 - 17:41 BST

Update

Findmyaddress.co.uk still remains offline. An update will be provided tomorrow before 5.30pm. Sorry for any problems this is causing.
Posted Aug 19, 2026 - 17:33 BST

Update

Findmyaddress.co.uk still remains offline. An update will be provided tomorrow before 5.30pm. Sorry for any problems this is causing.
Posted Aug 18, 2026 - 17:32 BST

Update

Findmyaddress.co.uk still remains offline. An update will be provided tomorrow before 5.30pm. Sorry for any problems this is causing.
Posted Aug 17, 2026 - 17:21 BST

Update

Findmyaddress.co.uk still remains offline this morning. We are hoping to provide an update later today.
Posted Aug 17, 2026 - 09:51 BST

Update

Findmyaddress.co.uk is offline. We anticipate the site to be unavailable into next week, and will provide an update on Monday 17th August.

We are sorry for any issues this is causing and are working with our providers to get the site back up as soon as possible.
Posted Aug 13, 2026 - 16:44 BST

Update

Findmystreet is now available again. Findmyaddress is still under maintenance.
Posted Aug 13, 2026 - 10:57 BST

Identified

Findmyaddress and findmystreet services currently offline for some essential maintenance. Apologies for any inconvenience. We will update with an estimated time this is due to be available as soon as we have more information.
Posted Aug 13, 2026 - 09:28 BST
This incident affects: FindMyAddress website and FindMyStreet website.